The How-To Website Has Been Updated.

How-To articles are in here. Please use sub-forum for requests
Post Reply
Shipkiller
Lifer
Lifer
Posts: 4143
Joined: Sat Oct 27, 2007 11:54 pm

The How-To Website Has Been Updated.

Post by Shipkiller » Sun Mar 01, 2009 10:57 pm

Since I am now back home, I had some time to update my Z4 How-To Maintenance Web Site.

http://www.shipkiller.com

I have added some new stuff. More to add.

If anyone has anything they would like to add, please PM me and I can get it up on the site.
Drives 2008 Z4MC (His) & 2003 Z4 Roadster (Her's)

Shipkiller
Lifer
Lifer
Posts: 4143
Joined: Sat Oct 27, 2007 11:54 pm

Re: The How-To Website Has Been Updated.

Post by Shipkiller » Mon Apr 06, 2009 11:42 pm

Just updated the website again.

The two PDF's for the soft top removal and soft top motor replacement are up there.

I have also added a link for all you Z4M and Z4MC owners. There is a page for maintenance that is just for the S54 engine.

Currently I only have two things up there:
1. A How-To for adjusting your valves . It was written for the M3, but everything is the same. Just ignore the M3 trim removal.
2. A picture that shows you where your Vano's Oil filter is.

The really only big drawback I had for getting a Z4MC was the valve adjustment. The dealer charges around $1600 for this. After reading the How-To, no problems.. It looks really easy.
Drives 2008 Z4MC (His) & 2003 Z4 Roadster (Her's)

User avatar
WLH
Lifer
Lifer
Posts: 12276
Joined: Fri Jun 15, 2007 2:08 am
Location: Taxsylvania
Contact:

Re: The How-To Website Has Been Updated.

Post by WLH » Mon Apr 06, 2009 11:57 pm

Your the man... :thumbsup:
2007 ///M Roadster - My Zed's - Member ZSCCA - ///M Registry - My Videos
Image

User avatar
Elliot
Member
Member
Posts: 186
Joined: Thu Aug 09, 2007 3:21 pm
Location: Hants/Berks Border, England
Contact:

Re: The How-To Website Has Been Updated.

Post by Elliot » Tue Apr 07, 2009 7:07 am

Very nice info there shipkiller :thumbsup:
Ive saved a few of your .pdf's for future ref. material :D
SOLD 2006 Z4 ///M Roadster in Imola Red....As seen below
http://www.pbase.com/elliot_d/bmw_z4_m

Shipkiller
Lifer
Lifer
Posts: 4143
Joined: Sat Oct 27, 2007 11:54 pm

Re: The How-To Website Has Been Updated.

Post by Shipkiller » Tue Apr 07, 2009 7:32 pm

That's what they are there for.
Drives 2008 Z4MC (His) & 2003 Z4 Roadster (Her's)

Shipkiller
Lifer
Lifer
Posts: 4143
Joined: Sat Oct 27, 2007 11:54 pm

Re: The How-To Website Has Been Updated.

Post by Shipkiller » Tue May 19, 2009 2:23 am

As some of you know, the site went down over the weekend. It is backup but some of the links do not work yet. Working on it...
Drives 2008 Z4MC (His) & 2003 Z4 Roadster (Her's)

Shipkiller
Lifer
Lifer
Posts: 4143
Joined: Sat Oct 27, 2007 11:54 pm

Re: The How-To Website Has Been Updated.

Post by Shipkiller » Mon May 25, 2009 1:04 am

The How-To Web Site has been updated. I will be adding more stuff in the following days.

Any requests?
Drives 2008 Z4MC (His) & 2003 Z4 Roadster (Her's)

Z4 REX
Member
Member
Posts: 68
Joined: Wed May 06, 2009 6:56 pm
Location: North East

Re: The How-To Website Has Been Updated.

Post by Z4 REX » Mon May 25, 2009 5:26 pm

Hello shipkiller. Is there something wrong with your website as it won't load?

Z4 REX
Member
Member
Posts: 68
Joined: Wed May 06, 2009 6:56 pm
Location: North East

Re: The How-To Website Has Been Updated.

Post by Z4 REX » Mon May 25, 2009 5:30 pm

Hello shipkiller. Is there something wrong with your website as it won't load?

Shipkiller
Lifer
Lifer
Posts: 4143
Joined: Sat Oct 27, 2007 11:54 pm

Re: The How-To Website Has Been Updated.

Post by Shipkiller » Mon May 25, 2009 6:25 pm

Rex, Thanks for the tip.

I had inadvertently kill a service. fixed now...
Drives 2008 Z4MC (His) & 2003 Z4 Roadster (Her's)

Z4 REX
Member
Member
Posts: 68
Joined: Wed May 06, 2009 6:56 pm
Location: North East

Re: The How-To Website Has Been Updated.

Post by Z4 REX » Mon May 25, 2009 7:24 pm

Thanks shipkiller your a gent.

Shipkiller
Lifer
Lifer
Posts: 4143
Joined: Sat Oct 27, 2007 11:54 pm

Re: The How-To Website Has Been Updated.

Post by Shipkiller » Mon May 25, 2009 7:52 pm

Adding more content as I type...
Drives 2008 Z4MC (His) & 2003 Z4 Roadster (Her's)

Z4 REX
Member
Member
Posts: 68
Joined: Wed May 06, 2009 6:56 pm
Location: North East

Re: The How-To Website Has Been Updated.

Post by Z4 REX » Mon May 25, 2009 7:58 pm

Thanks shipkiller your a gent.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests