A few error codes, hands in my pocket time!

Discuss problems you have had or are having with your Z4
Post Reply
User avatar
dhobbs
Member
Member
Posts: 702
Joined: Mon Jul 16, 2012 5:33 pm

A few error codes, hands in my pocket time!

Post by dhobbs » Wed Oct 11, 2017 7:57 pm

I've just got Carly and read my error codes.
Fan control: 002EFE
Is this the water pump or the radiator fan?

DSC: 005DF0 and 005DF1
I'm assuming this is the ABS pump/ECU. I do have the dreaded 3 lights on. Could it be an ABS sensor or am I just wishing?

AirCon recirculation flap:
000022
Could this be due to the engine being switched off? I know the flap usually closes as you switch the engine off.


Any advice welcome, but looks like an expensive month.
3.0si roadster. Requisite stubby. Sound gen mod. LED numberplate lights. LED boot strip. Interior lights LED too. Dension. ZHP gearknob. Daily drive :driving:
Motor in boot now! Bilstein b12 kit now fitted.

User avatar
abar121
Member
Member
Posts: 232
Joined: Tue Apr 26, 2011 9:14 pm

A few error codes, hands in my pocket time!

Post by abar121 » Wed Oct 11, 2017 8:37 pm

I had similar codes for the DSC unit and they refer to the Bosch ABS pump itself, not the sensors. Get it removed and sent to ECU Testing.

It is possible to do this yourself, but it's not exactly fun messing around with all those hard lines with fluid everywhere :)

They will test, fit new bushes etc if needed and send it back with a lifetime guarantee. About £220.
'07 Z4M Interlagos Blue. All options except extended leather.

User avatar
dhobbs
Member
Member
Posts: 702
Joined: Mon Jul 16, 2012 5:33 pm

A few error codes, hands in my pocket time!

Post by dhobbs » Wed Oct 11, 2017 9:57 pm

Yeah, I'm in denial at the moment with the abs pump, but I know it's inevitable.
When you disconnect the pump, does all the fluid drain from the reservoir?
3.0si roadster. Requisite stubby. Sound gen mod. LED numberplate lights. LED boot strip. Interior lights LED too. Dension. ZHP gearknob. Daily drive :driving:
Motor in boot now! Bilstein b12 kit now fitted.

User avatar
dhobbs
Member
Member
Posts: 702
Joined: Mon Jul 16, 2012 5:33 pm

A few error codes, hands in my pocket time!

Post by dhobbs » Thu Oct 12, 2017 5:38 pm

Any suggestions on the fan motor or the recirculation flap?

The fan code may be a sensor or it could be the fan itself. Any experiences on Z4s? Which fuses do the fan?

The recirculation flap could be the actuator. Is this buried in the dash somewhere?

Daz
3.0si roadster. Requisite stubby. Sound gen mod. LED numberplate lights. LED boot strip. Interior lights LED too. Dension. ZHP gearknob. Daily drive :driving:
Motor in boot now! Bilstein b12 kit now fitted.

User avatar
ph001
Member
Member
Posts: 636
Joined: Mon Oct 31, 2016 5:53 pm
Location: N. Yorkshire.

A few error codes, hands in my pocket time!

Post by ph001 » Thu Oct 12, 2017 6:01 pm

Do you have INPA? I'm pretty sure 002EFE is the electric radiator fan - you can turn it on and off manually in INPA to test. I'm not sure it has a fuse in the main fuse box, so it must be fused elsewhere.... viewtopic.php?f=3&t=38888
2007 E85 Z4 3.0Si manual :driving:
19" CSL's | Eibach Springs | Aeroskirts | Z4M front bumper | Clear brake light | ZHP | RCH+| Stubby

2004 E46 M3 coupe manual.

User avatar
dhobbs
Member
Member
Posts: 702
Joined: Mon Jul 16, 2012 5:33 pm

A few error codes, hands in my pocket time!

Post by dhobbs » Thu Oct 12, 2017 7:21 pm

ph001 wrote:
Thu Oct 12, 2017 6:01 pm
Do you have INPA? I'm pretty sure 002EFE is the electric radiator fan - you can turn it on and off manually in INPA to test. I'm not sure it has a fuse in the main fuse box, so it must be fused elsewhere.... viewtopic.php?f=3&t=38888
I have Carly, only just got it so not sure what it can do.
I shall have a look at the fuses first. Thanks
3.0si roadster. Requisite stubby. Sound gen mod. LED numberplate lights. LED boot strip. Interior lights LED too. Dension. ZHP gearknob. Daily drive :driving:
Motor in boot now! Bilstein b12 kit now fitted.

User avatar
abar121
Member
Member
Posts: 232
Joined: Tue Apr 26, 2011 9:14 pm

A few error codes, hands in my pocket time!

Post by abar121 » Fri Oct 13, 2017 4:37 pm

dhobbs wrote:
Wed Oct 11, 2017 9:57 pm
Yeah, I'm in denial at the moment with the abs pump, but I know it's inevitable.
When you disconnect the pump, does all the fluid drain from the reservoir?
Yeah, although I syringed mine out as it was due a fluid change anyway.

You need to undo all of the hard lines, unplug it, then take out the right front arch liner (or just the bolts on that side and bungee it down).

You can then undo the bottom pump mounting nut and extract the unit from the wheel arch.

I used ISTA+ to clear all the codes and then cycle the abs pump when bleeding, after refitting. I did disconnect the battery, but you still get tons of codes to reset afterwards.

http://www.instructables.com/id/BMW-Z4- ... e-removal/
'07 Z4M Interlagos Blue. All options except extended leather.

User avatar
dhobbs
Member
Member
Posts: 702
Joined: Mon Jul 16, 2012 5:33 pm

A few error codes, hands in my pocket time!

Post by dhobbs » Fri Oct 13, 2017 8:45 pm

I've been bad and booked it into Munich Legends to sort out. I just don't have the time to do this myself, got a holiday next week followed by working away for two weeks afterwards.
It's one of those things about time and money, I only have one and not the other. Annoyingly I'm working away to earn extra money, only to pay for things I could have done if I didn't go away :cry:
3.0si roadster. Requisite stubby. Sound gen mod. LED numberplate lights. LED boot strip. Interior lights LED too. Dension. ZHP gearknob. Daily drive :driving:
Motor in boot now! Bilstein b12 kit now fitted.

andyfanshawe
Member
Member
Posts: 344
Joined: Sun Jan 10, 2016 8:20 am
Location: Chesterfield UK

A few error codes, hands in my pocket time!

Post by andyfanshawe » Fri Oct 13, 2017 10:05 pm

abar121 wrote:
Fri Oct 13, 2017 4:37 pm
dhobbs wrote:
Wed Oct 11, 2017 9:57 pm
Yeah, I'm in denial at the moment with the abs pump, but I know it's inevitable.
When you disconnect the pump, does all the fluid drain from the reservoir?
Yeah, although I syringed mine out as it was due a fluid change anyway.

You need to undo all of the hard lines, unplug it, then take out the right front arch liner (or just the bolts on that side and bungee it down).

You can then undo the bottom pump mounting nut and extract the unit from the wheel arch.

I used ISTA+ to clear all the codes and then cycle the abs pump when bleeding, after refitting. I did disconnect the battery, but you still get tons of codes to reset afterwards.

http://www.instructables.com/id/BMW-Z4- ... e-removal/
Hold the brake pedal down with a block of wood between the seat and the pedal, and you will lose hardly any fluid. There will be no fluid flow through the pipes from the master cylinder.
You don't need to use any scanner or software to bleed the system. Trust me on this. Lost count on how many I have done.

Best of luck with it. I've used ecu testing in Heanor in Derbyshire loads of times. No comebacks at all. Cheap and easy fix.

Andy.

User avatar
dhobbs
Member
Member
Posts: 702
Joined: Mon Jul 16, 2012 5:33 pm

A few error codes, hands in my pocket time!

Post by dhobbs » Sat Oct 14, 2017 9:36 am

I'm getting them to look at my rear subframe and all its bushes at the same time. I've got a creaking sound from the rear even after ARB and new shocks/springs and topmounts.
3.0si roadster. Requisite stubby. Sound gen mod. LED numberplate lights. LED boot strip. Interior lights LED too. Dension. ZHP gearknob. Daily drive :driving:
Motor in boot now! Bilstein b12 kit now fitted.

Post Reply

Who is online

Users browsing this forum: Wildfire, Yahoo [Bot] and 22 guests