2007 z43.0si tapping noise

Discuss problems you have had or are having with your Z4

2007 z43.0si tapping noise

Postby Daveabc7 - Mon Jan 10, 2011 5:19 pm

I have a 2007 Z4 3.0si bought as a CPO from Morristown BMW. I brought it to the dealership for a rattle in the dash, they asked if the car was making a tapping noise. I told them I wasn’t hearing anything but since the car was in for service, they would update the exhaust lifters as it was bound to be making the noise eventually and it’s better that it’s covered under warranty.
I got the car back and it was making a very noticeable noise at this time. They told me the next step was to have the head replaced, which was done and again, the noise was very noticeable. They have now replaced the lifters in the new head and they tell me that everything checks out. They said there is a tapping noise at startup but this is normal for this engine, as long as it only lasts for between 30 to 45 seconds.
My question, is this true? If there is a tapping noise at startup, should I be concerned or is this just normal operation and maybe I wasn’t aware of the noise previously.

Thanks for your time.

David Dreispan
Daveabc7
Newbie
Newbie
 
Posts: 2
Joined: Sat Sep 25, 2010 4:51 pm
Country: United States (us)

Re: 2007 z43.0si tapping noise

Postby mason storm - Mon Jan 10, 2011 11:46 pm

See this thread for more info viewtopic.php?f=3&t=21412
3.0 si Sport Coupe
mason storm
Member
Member
 
Posts: 747
Joined: Fri Feb 29, 2008 5:17 pm

Re: 2007 z43.0si tapping noise

Postby doofus4000 - Tue Jan 11, 2011 10:26 am

From what I have read, people who have had the upgraded lifters fitted have had the tapping noise cured. Im guessing as you have had this fix that there must be something not right.

I was not fortunate enough to have the lifters or head fitted as my 3.0si was out of warranty but I found during a recent service that changing the type of oil cured the tapping noise thankfully (which was driving me insane by the way). Check out the thread that mason storm has linked.
doofus4000
Member
Member
 
Posts: 648
Joined: Tue Aug 10, 2010 11:18 pm
Country: United Kingdom (uk)

Re: 2007 z43.0si tapping noise

Postby srhutch - Tue Jan 11, 2011 2:35 pm

doofus4000 wrote:From what I have read, people who have had the upgraded lifters fitted have had the tapping noise cured. Im guessing as you have had this fix that there must be something not right.

I was not fortunate enough to have the lifters or head fitted as my 3.0si was out of warranty but I found during a recent service that changing the type of oil cured the tapping noise thankfully (which was driving me insane by the way). Check out the thread that mason storm has linked.


Not quite true I'm afraid, a number of folk have had the lifters only replaced and still find the issue. The head was redesigned with a non return valve which I believe is the only true fix unless they have redesigned lifter with non return valves which I don't believe is the case.

Here's my original thread and link to e90post.com and the 77 page thread on that forum.

viewtopic.php?f=3&t=10937&p=161535&hilit=+n52+engine+srhutch#p161535
Image Black Sapphire|Imola Red Leather|CFL|BT|Nav|DSP|CD Changer|Aux|Heated Seats|PDC|Black Grills|Intravee|Illuminated ZHP|Aero Skirts|OEM CSL's|Strut Brace
Image
srhutch
Lifer
Lifer
 
Posts: 15244
Joined: Tue Jun 19, 2007 1:22 pm
Location: East Sussex, UK
Country: United Kingdom (uk)

Re: 2007 z43.0si tapping noise

Postby doofus4000 - Tue Jan 11, 2011 2:45 pm

O dear not so good then, I stand corrected.
doofus4000
Member
Member
 
Posts: 648
Joined: Tue Aug 10, 2010 11:18 pm
Country: United Kingdom (uk)

Re: 2007 z43.0si tapping noise

Postby Gerry - Tue Jan 11, 2011 5:54 pm

doofus4000 wrote:From what I have read, people who have had the upgraded lifters fitted have had the tapping noise cured. Im guessing as you have had this fix that there must be something not right.

I was not fortunate enough to have the lifters or head fitted as my 3.0si was out of warranty but I found during a recent service that changing the type of oil cured the tapping noise thankfully (which was driving me insane by the way). Check out the thread that mason storm has linked.


Interesting point about the oil , Iv been following the 'oil threads' and have noticed that in general ,forum members are very particular about what they put in the Zed , Im assuming that the oil BMW put in is thicker thus not bleeding from the lifters , any idea what they put in Doofus .

edit , just had a read at srhutches post on the lifter probs with 2.5 and 3.0 and Im still puzzled as to what engines in my car ( it goes quite fast :) ) the cars a 2004 2.5 , does this car have the dodgy lifters ?
2.5 Maldives Blue, tottaly original , no mods,
Gerry
Member
Member
 
Posts: 357
Joined: Sat May 01, 2010 11:03 am
Country: United Kingdom (uk)

Re: 2007 z43.0si tapping noise

Postby doofus4000 - Tue Jan 11, 2011 7:22 pm

Gerry wrote:
doofus4000 wrote:From what I have read, people who have had the upgraded lifters fitted have had the tapping noise cured. Im guessing as you have had this fix that there must be something not right.

I was not fortunate enough to have the lifters or head fitted as my 3.0si was out of warranty but I found during a recent service that changing the type of oil cured the tapping noise thankfully (which was driving me insane by the way). Check out the thread that mason storm has linked.


Interesting point about the oil , Iv been following the 'oil threads' and have noticed that in general ,forum members are very particular about what they put in the Zed , Im assuming that the oil BMW put in is thicker thus not bleeding from the lifters , any idea what they put in Doofus .

edit , just had a read at srhutches post on the lifter probs with 2.5 and 3.0 and Im still puzzled as to what engines in my car ( it goes quite fast :) ) the cars a 2004 2.5 , does this car have the dodgy lifters ?


Yours is the M54 engine - I think the M54B25 version - I am not sure whether this problem exists in your engine but im sure someone will fill you in on here as there are plenty of z4 owners with this engine.

BMW recommends a couple of different specs of oil - BMW longlife01 and longlife 04 - for the N52 anyway its the 04 spec which is a 5-30 oil and personally I think its useless as changing oil types solved the tapping noise for me.
doofus4000
Member
Member
 
Posts: 648
Joined: Tue Aug 10, 2010 11:18 pm
Country: United Kingdom (uk)

Re: 2007 z43.0si tapping noise

Postby mason storm - Tue Jan 11, 2011 8:20 pm

srhutch wrote:
doofus4000 wrote:From what I have read, people who have had the upgraded lifters fitted have had the tapping noise cured. Im guessing as you have had this fix that there must be something not right.

I was not fortunate enough to have the lifters or head fitted as my 3.0si was out of warranty but I found during a recent service that changing the type of oil cured the tapping noise thankfully (which was driving me insane by the way). Check out the thread that mason storm has linked.


Not quite true I'm afraid, a number of folk have had the lifters only replaced and still find the issue. The head was redesigned with a non return valve which I believe is the only true fix unless they have redesigned lifter with non return valves which I don't believe is the case.

Here's my original thread and link to e90post.com and the 77 page thread on that forum.

viewtopic.php?f=3&t=10937&p=161535&hilit=+n52+engine+srhutch#p161535


Where you say the head has been re disigned with non return valve, was this something that was changed on later cars or do you mean the re designed head is what BMW use to fix the problem if it occurs?

I have an 09 registered 3.0si for which the warranty runs out in Feb 2012 and am concerened mine may start making this noise after the warranty runs out.
3.0 si Sport Coupe
mason storm
Member
Member
 
Posts: 747
Joined: Fri Feb 29, 2008 5:17 pm

Re: 2007 z43.0si tapping noise

Postby doofus4000 - Tue Jan 11, 2011 8:29 pm

I think I remember srhutch saying at some stage that on X year of car the new head was used..Id be pretty sure yours will be ok!
doofus4000
Member
Member
 
Posts: 648
Joined: Tue Aug 10, 2010 11:18 pm
Country: United Kingdom (uk)

Re: 2007 z43.0si tapping noise

Postby srhutch - Tue Jan 11, 2011 11:28 pm

mason storm wrote:
srhutch wrote:
doofus4000 wrote:From what I have read, people who have had the upgraded lifters fitted have had the tapping noise cured. Im guessing as you have had this fix that there must be something not right.

I was not fortunate enough to have the lifters or head fitted as my 3.0si was out of warranty but I found during a recent service that changing the type of oil cured the tapping noise thankfully (which was driving me insane by the way). Check out the thread that mason storm has linked.


Not quite true I'm afraid, a number of folk have had the lifters only replaced and still find the issue. The head was redesigned with a non return valve which I believe is the only true fix unless they have redesigned lifter with non return valves which I don't believe is the case.

Here's my original thread and link to e90post.com and the 77 page thread on that forum.

viewtopic.php?f=3&t=10937&p=161535&hilit=+n52+engine+srhutch#p161535


Where you say the head has been re disigned with non return valve, was this something that was changed on later cars or do you mean the re designed head is what BMW use to fix the problem if it occurs?

I have an 09 registered 3.0si for which the warranty runs out in Feb 2012 and am concerened mine may start making this noise after the warranty runs out.


BMW would fit the revised head from a certain point, when that was I don't know, my head was replaced in Apr 09, so if you car was built after this date there is a good chance it has then new head. You need to check under the bonnet for the build date (offside strut IIRC) as it's not unknown for cars to get for 12 months or so before they are registered.
Image Black Sapphire|Imola Red Leather|CFL|BT|Nav|DSP|CD Changer|Aux|Heated Seats|PDC|Black Grills|Intravee|Illuminated ZHP|Aero Skirts|OEM CSL's|Strut Brace
Image
srhutch
Lifer
Lifer
 
Posts: 15244
Joined: Tue Jun 19, 2007 1:22 pm
Location: East Sussex, UK
Country: United Kingdom (uk)

Re: 2007 z43.0si tapping noise

Postby Daveabc7 - Thu Feb 03, 2011 4:13 pm

I had a BMW FSE come out to the dealership and he said the tapping noise shouldn't be there. He had the dealership change the intake lifters on the new head and the tapping persisted. He then recommended a new head thinking the one that was replaced earlier was defective. The dealership contacted BMW NA to authorize the warranty work and they instructed them to replace the exhaust manifold gasket. It seems if it is not put on perfectly true when the engine was assembled, it will mimick an intake lifter tapping noise. I picked the car up yesterday and there was no tapping noise when the car was started.
Thanks to everyone that left postings offering suggestions, it is appreciated.
Daveabc7
Newbie
Newbie
 
Posts: 2
Joined: Sat Sep 25, 2010 4:51 pm
Country: United States (us)


Return to E85 - E86 Problems

Who is online

Users browsing this forum: Dale_B, mr wilks, olekfer, TomHitmanHatton and 13 guests

cron
-